• 6
    • 64 semanas
    • Categoria: Instalação
    • Tags: linux, debian
    Instalação do MUAN no Linux Mint (Debian Edition)
    por rpgmem
    Senhores

    Estou com problemas para instalar o pacote .deb no Linux Mint Debian Edition (dependências faltando). Poderiam por gentileza informar como solucionar o problema?

    Grato!
  • BrunoSouza

    64 semanas

    Olá,
    As bibliotecas necessárias para o funcionamento do muan são:

    libfltk1.1
    libdc1394-22
    libsamplerate0
    libdv4
    libavc1394-0
    libiec61883-0
    libv4l-0
  • rpgmem

    64 semanas

    Olá Bruno, muito obrigado pela resposta!

    Instalei as dependências e tentei novamente instalar usando o arquivo .deb (64x)

    O Synaptic apresenta o seguinte erro:
    Erro: A dependência não é contentável: libjpeg8 (>=8b-1)

    Como proceder a partir dai?
  • BrunoSouza

    64 semanas

    Olha achei um tópico falando sobre quebra de dependência no Mint:
    http://www.linuxmint.com.br/forum/t-3518/resolvido-problema-com-apt-get-e-dpkg.html

    Como é algo bem mais técnico é bom dar uma olhada nos comandos com calma e estudar o funcionamento de cada comando e os possíveis problemas que podem ser gerados se executados no sistema.
  • rpgmem

    63 semanas

    Oi Bruno
    Novamente obrigado pela resposta, tentei instalar usando dkpg e gdeb, porém essa dependência não está listada no repositório padrão, por isso ele não "pega" a dependência e instala automaticamente.

    Para "resolver" eu primeiro instalei as dependências citadas usando o terminal (Control+Alt+T):
    sudo apt-get install libfltk1.1 libdc1394-22 libsamplerate0 libdv4 libavc1394-0 libiec61883-0 libv4l-0

    Depois baixei manualmente a dependência "exótica" que faltava, aqui:
    https://packages.debian.org/pt-br/sid/libjpeg8

    Por fim baixei o pacote do Muan aqui no site e instalei sem problemas.

    Penso que a equipe do Muan poderia fazer um PPA ou algo do gênero para facilitar essa instalação, com todas as dependências corretamente apontadas e serem instalada diretamente, sem grade interação do usuário (o que seria esperado). Incluir este programa nos repositórios padrão seriam realmente excelente, desta forma todo mundo teriam sempre o programa atualizado sem interações manuais que poderiam gerar erros diversos ao sistema.

    Grato pela ajuda e fica ai a documentação para caso alguém necessite ;-)
  • BrunoSouza

    63 semanas

    rpgmem, Obrigado pelo retorno :)
  • danieldan

    38 semanas

    Muito Fácil Mesmo, Valeu Pelas Respostas !!!

    Daniel do Site: http://fazerdinheiroonline.net.br